Inter Projekt
 
www.InterProjekt.pl  
Teraz jest 18 października 2017, godz. 00:32

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 7 ] 
Autor Wiadomość
 Tytuł: Jak ograniczyć ruch p2p
PostNapisane: 27 sierpnia 2009, godz. 13:59 
Offline

Dołączył(a): 18 maja 2009, godz. 22:54
Posty: 36
Witam, chciałbym ograniczyć sam ruch p2p, nie zablokować ale tylko ograniczyć. Czy ma ktoś pomysł jak to skutecznie zrobić?
Teraz zrobiłem to metodą kolegi Smith z tego wątku http://forum.interprojekt.pl/ograniczenie-ruchu-p2p-t79.html

Cytuj:
Może nie dokońca na temat ale przykład jak ograniczyć wszystkich userów na MT"przykład oczywiście można znaleśc w necie :D"

1. Zaznaczamy wszystkie pakiety "packet-mark all":

/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=all passthrough=no

2. Konfigurujemy kolejki PCQ queue types - jendą dla "download (dst-address)" oraz jedną dla "upload (src-address)".

/queue type add name="PCQ_download" kind=pcq pcq-rate=128000 pcq-classifier=dst-address
/queue type add name="PCQ_upload" kind=pcq pcq-rate=64000 pcq-classifier=src-address
3. Ostatecznie dwie kolejki są gotowe, jedna dla "download" i jedna dla "upload":

/queue tree add parent=global-in queue=PCQ_download packet-mark=all
/queue tree add parent=global-out queue=PCQ_upload packet-mark=all

Jeżeli nie lubisz używac markowania i "kolejek", możesz pominąc kroki 1-3 i utworzyć jedną kolejkę wyglądającą mniej więcej tak:

/queue simple add queue=PCQ_upload/PCQ_download target-addresses=192.168.0.0/24

To wszystko :D


Niby działa, ale nie jestem pewien czy ta metoda ogranicza mi tylko p2p czy wszystko. A mi chodzi tylko o p2p.

Z góry dzięki za pomoc


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Jak ograniczyć ruch p2p
PostNapisane: 28 sierpnia 2009, godz. 00:46 
Offline
Inter Projekt
Avatar użytkownika

Dołączył(a): 5 marca 2007, godz. 11:31
Posty: 170
Lokalizacja: Bytom
Witam,

A gdzie markujesz ruch p2p? Te kolejki działają globalnie i ograniczają podkolejki kolejek pcq do wartości, które tam wpisałeś.

W mangle musisz dodać regułkę wykorzystującą parametr p2p

Kod:
add action=mark-connection chain=prerouting comment="p2p mark" disabled=no \
    new-connection-mark=p2p-c p2p=bit-torrent passthrough=yes
add action=mark-packet chain=prerouting comment="" connection-mark=p2p-c \
    disabled=no new-packet-mark=p2p-p passthrough=no


a potem wykorzystać ten packet-mark w kolejkach queue tree

Kod:
add disabled=no limit-at=64k  max-limit=128k name=p2p-upload packet-mark=p2p-p\
     parent=Global-Upload



Oczywiście parametr parent to kolejka tnąca globalnie dla danego interfejsu.


pozdrawiam


Góra
 Zobacz profil  
 
 Tytuł: Re: Jak ograniczyć ruch p2p
PostNapisane: 29 sierpnia 2009, godz. 09:32 
Offline

Dołączył(a): 18 maja 2009, godz. 22:54
Posty: 36
tzn tak, chce ograniczyć ruch p2p który przechodzi przez jeden mikrotik w mojej sieci. I żadnych opcji w firewall ani w Queues nie mam dodanych. Więc Byłbym wdzięczny jak byś wytłumaczył mi to od początku, co i jak trzeba ustawić aby ograniczało mi ruch p2p na tym mikrotiku.


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Jak ograniczyć ruch p2p
PostNapisane: 13 września 2009, godz. 08:26 
Offline

Dołączył(a): 1 kwietnia 2007, godz. 15:52
Posty: 61
Lokalizacja: Zdzieszowice
Że tak wtrącę. Wytnij też wszystkie pakiety większe niż 1500b, bo niektóre ustrojstwa potrafią w jakiś tajemniczy sposób obejść ograniczenia i walić pełną prędkością łącza wysyłając nieco przyduże pakiety. Po tej operacji kilku klientów dziwnie zaczęło narzekać, że im się Ares "zepsuł" cosik :mrgreen:


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Jak ograniczyć ruch p2p
PostNapisane: 7 grudnia 2009, godz. 20:12 
Offline
Avatar użytkownika

Dołączył(a): 8 lipca 2007, godz. 16:03
Posty: 36
Ograniczenia p2p należy budować w oparciu o limitowanie ilości wysyłanych pakietów... :!:
To bardzo ważne, w momencie kiedy ktoś korzysta w normalny sposób z łącza wysyła mało ale dużych pakietów
wtedy sieć i karty sieciowe pracują stabilnie ponieważ są w stanie przesłać optymalną ilość pakietów/s.

W momencie kiedy ktoś pobiera bo protokole podobnym do p2p połączenie nawiązywane jest z ogromną ilością pakietów ale bardzo małych.
W efekcie karta sieciowa przy kilku klientach dostaje czkawki i nie jest poprostu w stanie ... mimo że nie wykorzystujemy w ogóle przepustowości.
Należy więc ograniczyć ilość pakietów np do 40p/s. Sytuacja zdecydowanie się poprawi, p2p będzie działać ale bardzo słabo inne usługi jak www bez najmniejszego problemu. Przy 40p/s dość szybko można pracować w necie... Przypisując klientowi transfer np 1Mbit włączył bym mu np 50p/s.

Przy połączeniu p2p przy 1Mbit zauważysz nawet do 250p/s to zdecydowanie za duzo ;]

pozdrawiam
Echo


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Jak ograniczyć ruch p2p
PostNapisane: 19 stycznia 2011, godz. 00:11 
Offline

Dołączył(a): 19 stycznia 2011, godz. 00:05
Posty: 1
Witam Cię "echo" bardzo zainteresowała mnie Twoja wypowiedź dotycząca limitowania łącza p2p.

Jestem nowy na forum i dopiero zaczynam przygodę z sieciami Wifi.

Mam postawionych kilka punktów na mikrotiku i mam problem z połączeniem p2p w godzinach 18-23 natężenie ruchu staje się zbyt duże co skutkuje lagami internetu w tym okresie.

Czy mógłbyś mnie troszkę naprowadzić by ograniczyć łącze w tych godzinach.

Chciałbym też ograniczyć ilość pakietów.

Liczę na Twoją pomoc.


Pozdrawiam hudy34


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Jak ograniczyć ruch p2p
PostNapisane: 21 lutego 2011, godz. 17:03 
Offline
Inter Projekt
Avatar użytkownika

Dołączył(a): 5 marca 2007, godz. 11:31
Posty: 170
Lokalizacja: Bytom
Witam,

W walce z P2P może też pomóć filtr L7 - http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/L7
Działa znacznie skuteczniej niże domyślny filtr z RouterOS

pozdrawiam,
bdr


Góra
 Zobacz profil  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 7 ] 

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]


Kto przegląda forum

Użytkownicy przeglądający to forum: Brak zalogowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Publikowane wiadomości są prywatnymi opiniami użytkowników forum. Inter Projekt S.A. nie ponosi odpowiedzialności za treść wiadomości.
Informacje o cookies