Inter Projekt
 
www.InterProjekt.pl  
Teraz jest 17 października 2017, godz. 15:22

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 4 ] 
Autor Wiadomość
 Tytuł: Ograniczenie ruchu P2P
PostNapisane: 19 maja 2006, godz. 13:51 
Offline

Dołączył(a): 4 marca 2006, godz. 13:05
Posty: 3
Lokalizacja: Poddębice
Chciałbym ograniczyć prędkość ściągania w programach typu P2P dla wszystkich ip w sieci np. 192.168.0.x
Czy ograniczenie w simple queues wystarczy ?
Może ktoś ma gotowe rozwiązanie ?


Góra
 Zobacz profil  
 
 Tytuł:
PostNapisane: 19 maja 2006, godz. 16:21 
Offline
Inter Projekt

Dołączył(a): 30 marca 2005, godz. 01:34
Posty: 43
Trzeba zamarkować pakiety p2p i zrobić ograniczenie w queue tree
Pozdrawia Inter Projekt
Dawid Papis


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Ograniczenie ruchu P2P
PostNapisane: 22 maja 2006, godz. 22:32 
Offline
Inter Projekt
Avatar użytkownika

Dołączył(a): 23 stycznia 2006, godz. 12:53
Posty: 80
Lokalizacja: Gliwice
slack napisał(a):
Chciałbym ograniczyć prędkość ściągania w programach typu P2P dla wszystkich ip w sieci np. 192.168.0.x
Czy ograniczenie w simple queues wystarczy ?
Może ktoś ma gotowe rozwiązanie ?

Może nie dokońca na temat ale przykład jak ograniczyć wszystkich userów na MT"przykład oczywiście można znaleśc w necie :D"

1. Zaznaczamy wszystkie pakiety "packet-mark all":

/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=all passthrough=no

2. Konfigurujemy kolejki PCQ queue types - jendą dla "download (dst-address)" oraz jedną dla "upload (src-address)".

/queue type add name="PCQ_download" kind=pcq pcq-rate=128000 pcq-classifier=dst-address
/queue type add name="PCQ_upload" kind=pcq pcq-rate=64000 pcq-classifier=src-address

3. Ostatecznie dwie kolejki są gotowe, jedna dla "download" i jedna dla "upload":

/queue tree add parent=global-in queue=PCQ_download packet-mark=all
/queue tree add parent=global-out queue=PCQ_upload packet-mark=all


Jeżeli nie lubisz używac markowania i "kolejek", możesz pominąc kroki 1-3 i utworzyć jedną kolejkę wyglądającą mniej więcej tak:

/queue simple add queue=PCQ_upload/PCQ_download target-addresses=192.168.0.0/24

To wszystko :D



Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł:
PostNapisane: 26 stycznia 2007, godz. 14:05 
Offline

Dołączył(a): 23 stycznia 2007, godz. 14:24
Posty: 91
Wszystkie manuale odnosnie MT znajdziesz tutaj : http://www.mikrotik.com/testdocs/ros/2.9/ .

Opcje ograniczania, blokowania uslug p2p znajdziesz w zakladce IP >> Firewall >> Filter Rules dodajesz nowy wpis dla konkretnego IP lub calej podsieci (src. Address) wybierasz program p2p ktory ma byc zablokowany lub ograniczony (P2P). Kolejne zakladki konfigurujesz wedlug wlasnego uznania w zaleznosci od tego co chcesz osiagnac.


Dziala na 100% mozesz tez limitowac transfer - nie tylko blokowac.


Góra
 Zobacz profil Wyślij e-mail  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 4 ] 

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]


Kto przegląda forum

Użytkownicy przeglądający to forum: Brak zalogowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Publikowane wiadomości są prywatnymi opiniami użytkowników forum. Inter Projekt S.A. nie ponosi odpowiedzialności za treść wiadomości.
Informacje o cookies