Inter Projekt
 
www.InterProjekt.pl  
Teraz jest 18 października 2017, godz. 00:30

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 6 ] 
Autor Wiadomość
 Tytuł: P2P inaczej
PostNapisane: 27 stycznia 2006, godz. 13:56 
Offline

Dołączył(a): 27 stycznia 2006, godz. 13:52
Posty: 25
Lokalizacja: Bargłówka
Witam,
Mam takie pytanko: jak zablokowac na MT P2P w wyznaczonych godzinach, bo jakos mi to nie wychodzi...:)


Góra
 Zobacz profil  
 
 Tytuł:
PostNapisane: 30 stycznia 2006, godz. 12:07 
Offline
Inter Projekt

Dołączył(a): 30 marca 2005, godz. 01:34
Posty: 43
jestem w trakcie opracowania takiej instrukcji i będzie ona opublikowana na tym forum
Pozdrawia Inter Projekt


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł:
PostNapisane: 6 lutego 2006, godz. 08:17 
Offline

Dołączył(a): 27 stycznia 2006, godz. 13:52
Posty: 25
Lokalizacja: Bargłówka
admin napisał(a):
jestem w trakcie opracowania takiej instrukcji i będzie ona opublikowana na tym forum
Pozdrawia Inter Projekt


Czekamy dalej z niecierpliwoscia. Moze na 2.9.12 bedzie to juz dzialalo :)


Góra
 Zobacz profil  
 
 Tytuł:
PostNapisane: 7 lutego 2006, godz. 02:32 
matt napisał(a):
admin napisał(a):
jestem w trakcie opracowania takiej instrukcji i będzie ona opublikowana na tym forum
Pozdrawia Inter Projekt


Czekamy dalej z niecierpliwoscia. Moze na 2.9.12 bedzie to juz dzialalo :)


Na szybko klepiac o 01:31 zrobilem takie cos(na mt 2.9.12),

jezeli w firewallu sa takie regulki :
/ip firewall filter
add chain=forward in-interface=wlan7 p2p=all-p2p action=drop comment="" disabled=yes
add chain=forward out-interface=wlan7 p2p=all-p2p action=drop comment="" disabled=yes
add chain=forward in-interface=wds7 p2p=all-p2p action=drop comment="" disabled=yes
add chain=forward out-interface=wds7 p2p=all-p2p action=drop comment="" disabled=yes

/ system script
add name="odb_p2p" source=":foreach i in=\[/ip firewall filter find p2p=all-p2p action=drop\] do={/ip firewall filter \
disable \$i}" policy=ftp,reboot,read,write,policy,test,winbox,password
add name="zab_p2p" source=":foreach i in=\[/ip firewall filter find p2p=all-p2p action=drop\] do={/ip firewall filter \
enable \$i}" policy=ftp,reboot,read,write,policy,test,winbox,password

/ system scheduler
add name="blokowanie_p2p_o_8_00" on-event=zab_p2p start-date=feb/07/2006 start-time=08:00:00 interval=1d comment="" \
disabled=no
add name="odblokowanie_p2p_o_23_59" on-event=odb_p2p start-date=feb/07/2006 start-time=23:59:00 interval=1d comment="" \
disabled=no

Nie testowalem ale powinno dzialac;)
Skrypty zab_p2p i odb_p2p dzialaja bez uwczesniejszego wyprintowania
zawartosci filtru.A scheduler chyba dobrze ustawilem...

Komenda podana w parametrze do petli foreach jest powtarzana dla kazdego wskaznika zwroconego w zmiennej i.Odpowiednio skrypty wylaczaja(odb_p2p) lub wlaczaja(zab_p2p) wszystkie regulki firewalla gdzie p2p=all-p2p i action=drop.

Nalezy pamietac zeby ustwaic odpowiednio /system clock.

Scheduler jest ustawiony aby co 24h o 8:00 wykonywal skrypt zab_p2p,
a o 23:59 odb_p2p.

Pozdrawiam,
bart[at]gaja.net.pl


Góra
  
 
 Tytuł:
PostNapisane: 7 lutego 2006, godz. 02:38 
Zapomnialem dodac ze musi byc wlaczony connection tracking zeby wykyrc p2p.(/ip firewall connection tracking set enabled=yes).
Zaznaczam ze waznym parametrem tablicy sledzenia jest jej wielkosc (count_max-maxymalna wielkosc i count_current-aktualnie uzywane). Przy jej zapchaniu MT raczej nie bedzie dobrze pracowal...

bart[at]gaja.net.pl napisał(a):
matt napisał(a):
admin napisał(a):
jestem w trakcie opracowania takiej instrukcji i będzie ona opublikowana na tym forum
Pozdrawia Inter Projekt


Czekamy dalej z niecierpliwoscia. Moze na 2.9.12 bedzie to juz dzialalo :)


Na szybko klepiac o 01:31 zrobilem takie cos(na mt 2.9.12),

jezeli w firewallu sa takie regulki :
/ip firewall filter
add chain=forward in-interface=wlan7 p2p=all-p2p action=drop comment="" disabled=yes
add chain=forward out-interface=wlan7 p2p=all-p2p action=drop comment="" disabled=yes
add chain=forward in-interface=wds7 p2p=all-p2p action=drop comment="" disabled=yes
add chain=forward out-interface=wds7 p2p=all-p2p action=drop comment="" disabled=yes

/ system script
add name="odb_p2p" source=":foreach i in=\[/ip firewall filter find p2p=all-p2p action=drop\] do={/ip firewall filter \
disable \$i}" policy=ftp,reboot,read,write,policy,test,winbox,password
add name="zab_p2p" source=":foreach i in=\[/ip firewall filter find p2p=all-p2p action=drop\] do={/ip firewall filter \
enable \$i}" policy=ftp,reboot,read,write,policy,test,winbox,password

/ system scheduler
add name="blokowanie_p2p_o_8_00" on-event=zab_p2p start-date=feb/07/2006 start-time=08:00:00 interval=1d comment="" \
disabled=no
add name="odblokowanie_p2p_o_23_59" on-event=odb_p2p start-date=feb/07/2006 start-time=23:59:00 interval=1d comment="" \
disabled=no

Nie testowalem ale powinno dzialac;)
Skrypty zab_p2p i odb_p2p dzialaja bez uwczesniejszego wyprintowania
zawartosci filtru.A scheduler chyba dobrze ustawilem...

Komenda podana w parametrze do petli foreach jest powtarzana dla kazdego wskaznika zwroconego w zmiennej i.Odpowiednio skrypty wylaczaja(odb_p2p) lub wlaczaja(zab_p2p) wszystkie regulki firewalla gdzie p2p=all-p2p i action=drop.

Nalezy pamietac zeby ustwaic odpowiednio /system clock.

Scheduler jest ustawiony aby co 24h o 8:00 wykonywal skrypt zab_p2p,
a o 23:59 odb_p2p.

Pozdrawiam,
bart[at]gaja.net.pl


Góra
  
 
 Tytuł:
PostNapisane: 15 lutego 2006, godz. 15:35 
Offline

Dołączył(a): 27 stycznia 2006, godz. 13:52
Posty: 25
Lokalizacja: Bargłówka
bardzo dziekuje - pocwicze to dzisiaj :)
Pozdrawiam


Góra
 Zobacz profil  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 6 ] 

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]


Kto przegląda forum

Użytkownicy przeglądający to forum: Brak zalogowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Publikowane wiadomości są prywatnymi opiniami użytkowników forum. Inter Projekt S.A. nie ponosi odpowiedzialności za treść wiadomości.
Informacje o cookies