Inter Projekt
 
www.InterProjekt.pl  
Teraz jest 17 października 2017, godz. 15:22

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 6 ] 
Autor Wiadomość
 Tytuł: Scheduler i skrypty
PostNapisane: 25 marca 2009, godz. 14:00 
Offline

Dołączył(a): 25 marca 2009, godz. 13:52
Posty: 4
Przepraszam za kłopot ale liczę na pomoc. Szukam juz odpowiedzi na mój problem od kilku godzin i nie mogę doszukać się.

Mam zainstalowanego Mikrotika jako bazę. Problemy zaczynają się wieczorem , gdy sieć generuje duży ruch. Rośnie ilość pakietów. Wpisałem do firewalla regułki ograniczające ilość pakietów. Eksperymentalnie ustawiłem parametry. DZIAŁA !!! Ale....
Co zrobić by skrypt ten włączał się i wyłączał o określonych godzinach????
Niby jest scheduler, niby można nakazać by uruchomił się skrypt )powiedzmy o godzinie 18) ale jak zrobić by on się wyłączył powiedzmy około godziny 1 w nocy?????

Pozdrawiam
Marek


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Scheduler i skrypty
PostNapisane: 26 marca 2009, godz. 10:44 
Offline

Dołączył(a): 20 maja 2008, godz. 10:38
Posty: 34
Zakładając że reguła w firewall filter ma numer 5 wpisujemy jako akcję w schedulerze na odpowiednią godzinę

Kod:
ip firewall filter set 5 disabled=yes


Pozdrawiam


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Scheduler i skrypty
PostNapisane: 26 marca 2009, godz. 13:58 
Offline

Dołączył(a): 25 marca 2009, godz. 13:52
Posty: 4
Korzystam s takiego skryptu:

:for l from 3 to 75 do={
/ip firewall filter add chain=forward dst-address=(10.0.0. . $l ) dst-limit=90,50,dst-address/1m action=accept comment="" disabled=no
/ip firewall filter add chain=forward dst-address=(10.0.0. . $l ) action=drop comment="" disabled=no
/ip firewall filter add chain=forward src-address=(10.0.0. . $l ) dst-limit=90,50,src-and-dst-address/1m action=accept comment="" disabled=no
/ip firewall filter add chain=forward src-address=(10.0.0. . $l ) action=drop comment="" disabled=no }

Wydrukowałem listę w firewall>filter.
Adresy IP w klasie 10.0.0.x

Na wydruku z ip>firewall>filter>print drukuje cała listę : od 0 do 291.

Czy Twój wpis można napisać "od - do"???
np.:
:for l from 0 to 291 do={ /ip firewall filter set $l disabled=yes } ma wyłączyć
:for l from 0 to 291 do={ /ip firewall filter set $l disabled=no } ma włączyć
W schedulerze robię dwa wpisy:

pierwszy włączający i ustalam godzinę
drugi wyłączający i ustalam inną godzinę.

Czy dobrze główkuję????
POzdrawiam


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Scheduler i skrypty
PostNapisane: 27 marca 2009, godz. 11:57 
Offline

Dołączył(a): 20 maja 2008, godz. 10:38
Posty: 34
Witam

Koncepcja wydaje się prawidłowa.
Pozostaje przetestowac :)

Pozdrawiam


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Scheduler i skrypty
PostNapisane: 27 marca 2009, godz. 14:51 
Offline

Dołączył(a): 25 marca 2009, godz. 13:52
Posty: 4
Niestety, nie działa. Po wklejeniu do okna scripts i uruchomieniu nic się dzieje.
Próbowałem wydać komendę w konsoli ip firewall filter disable 5. i wyłączył firewalla dla 5 wpisu.
Wpisanie tej samej linijki do scryptu i jego uruchomienie nic nie daje. licznik uruchomień pokazuje kolejne uruchomenie ale nic sie nie dzieje.
Co dalej????

Pozdrawiam
MArek


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Scheduler i skrypty
PostNapisane: 2 kwietnia 2009, godz. 19:37 
Offline

Dołączył(a): 25 marca 2009, godz. 13:52
Posty: 4
Nikt mi nie potrafi pomóc?????


Góra
 Zobacz profil Wyślij e-mail  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 6 ] 

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]


Kto przegląda forum

Użytkownicy przeglądający to forum: Brak zalogowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Publikowane wiadomości są prywatnymi opiniami użytkowników forum. Inter Projekt S.A. nie ponosi odpowiedzialności za treść wiadomości.
Informacje o cookies