Inter Projekt
 
www.InterProjekt.pl  
Teraz jest 18 października 2017, godz. 00:32

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 3 ] 
Autor Wiadomość
 Tytuł: Script Dynamic DNS
PostNapisane: 26 stycznia 2010, godz. 13:01 
Offline
Avatar użytkownika

Dołączył(a): 21 maja 2009, godz. 13:23
Posty: 43
Mam taki scrypcik do DDNS:
Kod:
# Definiujemy zmienne globalne
:global ddnsuser "............."
:global ddnspass "................."
:global ddnshost "............................"

# Definiujemy zmienne globalne
:global ddnsip
:global ddnslastip
:if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }

:global ddnsinterface
:global ddnssystem ("mt-" . [/system package get system version] )

# Definiujemy zmienne lokalne
:local int

# Loop thru interfaces and look for ones containing
# default gateways without routing-marks
:foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
  :if ([:typeof [/ip route get $int routing-mark ]] != str ) do={
    :global ddnsinterface [/ip route get $int interface]
  }
}
:log info $ddnsinterface

# Definiujemy zmienną globalną (aktualny adres IP na danym interfejsie)
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]

# Did we get an IP address to compare?
:if ([ :typeof $ddnsip ] = nil ) do={
  :log info ("DynDNS: No ip address present on " . $ddnsinterface . ", please check.")
} else={
  :if ($ddnsip != $ddnslastip) do={
    :log info "DynDNS: Sending UPDATE!"
/tool fetch address=members.dyndns.org src-path="/nic/update?system=dyndns&hostname=$ddnshost&myip=$ddnsip&wildcard=no"
user=$ddnsuser password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
  :delay 1
  :local str [/file find name="DynDNS.$ddnshost"];
  /file remove $str
  :global ddnslastip $ddnsip
  }
}


w miejsce kropek z początku scryptu oczywiście wstawiamy login, hasło i host'a z http://www.dyndns.com/
najwyraźniej gdzieś jest błąd bo nie działa mi poprawnie ..

jak ktoś ma jakieś pojęcie w temacie to będe bardzo wdzięczny za poprawki ..


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Script Dynamic DNS
PostNapisane: 26 stycznia 2010, godz. 13:12 
Offline

Dołączył(a): 31 października 2006, godz. 09:51
Posty: 293
Lokalizacja: Sosnowiec
Witam.

Jakiś czas temu temat był poruszany na forum, poniżej link do opisu konfiguracji :

http://www.interprojekt.pl/wiki/Wiki.js ... cja%20DDNS

Pamiętaj aby poprawnie skonfigurować clienta NTP bez tego skrypt nie będzie działać poprawnie.

Pozdrawiam.


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Script Dynamic DNS
PostNapisane: 26 stycznia 2010, godz. 21:32 
Offline
Avatar użytkownika

Dołączył(a): 21 maja 2009, godz. 13:23
Posty: 43
Dziękuje, scrypt jest ok tylko:

4.Uruchamiamy New Terminal i wklejamy kod2.
Kod:
/system scheduler
add comment="" disabled=no interval=5m name=DDNS on-event=\
    HomingBeacon-Simple policy=read,write,policy,test,password start-time=\
    startup


nie działa poprawnie .. tzn nie dodaje się z właściwą datą pomimo poprawnie działającego clienta NTP ..

problem rozwiązałem wykorzystując kod z Wiki MikroTik'a
Kod:
/system scheduler add name=DDNS interval=00:01 on-event="/system script run DDNS\r\n"


Może się komuś przyda ..


Góra
 Zobacz profil Wyślij e-mail  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 3 ] 

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]


Kto przegląda forum

Użytkownicy przeglądający to forum: Brak zalogowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Publikowane wiadomości są prywatnymi opiniami użytkowników forum. Inter Projekt S.A. nie ponosi odpowiedzialności za treść wiadomości.
Informacje o cookies