Inter Projekt
 
www.InterProjekt.pl  
Teraz jest 17 października 2017, godz. 15:20

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 2 ] 
Autor Wiadomość
 Tytuł: Sterowanie modemem na porcie szeregowym [Rozwiązane]
PostNapisane: 16 września 2010, godz. 18:42 
Offline

Dołączył(a): 16 kwietnia 2010, godz. 16:29
Posty: 3
Witajcie
Wpadłem na niecodzienny pomysł poprawy parametrów mojego łącza internetowego. Otóż linia jest strasznie zaszumiona i co jakiś czas SNR Margin na modemie ADSL spada do zera i zrywa połączenie. Po ponownym zestawieniu linku łącze ma jako-takie parametry ale SNR Margin powolutku spada i spada, i znowu do zera.
Zauważyłem jednak, że kiedy podniosę słuchawkę, to SNR Margin spada trochę, ale zaraz się podnosi o jakieś 3-4dB wyżej niż przed podniesieniem słuchawki. Stąd mój pomysł, aby do seriala mikrotika podpiąć stary zewnętrzny modem i kazać mu co 3 minuty podnieść i odłożyć słuchawkę (czyli ATH1 i ATH0).

Nie wiem jednak jak zmusić mikrotika RB411 z OS 4.11 do takiego właśnie wysterowania modemu. Macie jakieś pomysły?

Mnie przyszedł do głowy tylko taki, żeby ustawić klienta PPP i co 3 minuty puścić ping a dial on demand próbuje zadzwonić gdzieś w powietrze. Ale to nieeleganckie i jakoś tak dookoła. Może jest lepszy sposób?


Ostatnio edytowano 17 września 2010, godz. 15:57 przez twk, łącznie edytowano 1 raz

Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Sterowanie modemem na porcie szeregowym
PostNapisane: 17 września 2010, godz. 15:56 
Offline

Dołączył(a): 16 kwietnia 2010, godz. 16:29
Posty: 3
Ok, poradziłem sobie :)

Dzięki WIKI dowiedziałem się że RouterOS nie pozwala na bezpośrednie wysłanie tekstu na port szeregowy, ale można zrobić to wykorzystując ppp-client.

Teraz to już z górki, przygotowałem skrypt który wysyła do modemu ATH1 (off hook, czyli "podnieś słuchawkę"), czeka trzy sekundy i odkłada (on hook). Cały skrypt wygląda tak:

Kod:
/interface ppp-client add name="scripttemp" port=serial0 modem-init="ATH1"  disabled=no dial-on-demand=no
:log info "Modem OFF HOOK"
:delay 2
/interface ppp-client remove [/interface ppp-client find name="scripttemp"]
:delay 3
/interface ppp-client add name="scripttemp" port=serial0 modem-init="ATH0"  disabled=no dial-on-demand=no
:log info "Modem ON HOOK"
:delay 1
/interface ppp-client remove [/interface ppp-client find name="scripttemp"]


Teraz już tylko przygotowanie zadania schedulera do uruchamiania skryptu co jakiś czas, u mnie co 3 minuty:
Kod:
/system script run ath-flash-serial0

gdzie ath-flash-serial0 to nazwa mojego skryptu wysyłającego komendy do modemu.

Teraz już tylko pozostaje obserwować stan linii ADSL...


Góra
 Zobacz profil Wyślij e-mail  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 2 ] 

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]


Kto przegląda forum

Użytkownicy przeglądający to forum: Brak zalogowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Publikowane wiadomości są prywatnymi opiniami użytkowników forum. Inter Projekt S.A. nie ponosi odpowiedzialności za treść wiadomości.
Informacje o cookies