Inter Projekt
 
www.InterProjekt.pl  
Teraz jest 21 października 2017, godz. 01:13

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 7 ] 
Autor Wiadomość
 Tytuł: Zdalne Logowanie.
PostNapisane: 7 maja 2009, godz. 10:11 
Offline

Dołączył(a): 7 maja 2009, godz. 10:07
Posty: 25
Mam taki problem (nie tylko zapewne ja) ze w logach widze mnostwo nieudanych logowan po ssh.

Czy ktos moglby umiescic tutaj skrypt (lub opis takiej konfiguracji), zeby po okreslonej liczbie prob nieudanych logowan blokowal ten adres ip.


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Zdalne Logowanie.
PostNapisane: 7 maja 2009, godz. 23:13 
Offline
Avatar użytkownika

Dołączył(a): 12 grudnia 2006, godz. 15:38
Posty: 51
Lokalizacja: N=50°01' E=22°40'
Kod:
/ip firewall filter
add action=drop chain=forward comment=\
    "Blokuje wszystkich ktorzy znajduja sie na liscie Black_SSH" connection-state=new \
    disabled=no dst-port=22 protocol=tcp src-address-list=Black_SSH
add action=add-src-to-address-list address-list=Black_SSH address-list-timeout=1d chain=forward \
    comment="Dodaje IP ktore nawiązują wiele placzeń ssh na 1 dzie\F1 do listy Black_SSH" connection-limit=30,32 \
    disabled=no dst-port=22 limit=50,5 protocol=tcp


Moze to pomoze troche, lub naprowadzi.


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Zdalne Logowanie.
PostNapisane: 11 maja 2009, godz. 09:57 
Offline

Dołączył(a): 7 maja 2009, godz. 10:07
Posty: 25
lancuch forward czy input ?? no i czy moglbys troszke rozszyfrowac (po ilu polaczeniach dodaje do listy) itd, dzieki.


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Zdalne Logowanie.
PostNapisane: 11 maja 2009, godz. 15:55 
Offline

Dołączył(a): 31 października 2006, godz. 09:51
Posty: 293
Lokalizacja: Sosnowiec
Łańcuch na pewno input, ja mam u siebie coś takiego i działa bez problemu :

10 X ;;; logujemy po trzeciej probie ,bruteforce ssh poczatek
chain=input action=log src-address-list=ssh_bruteforce log-prefix=""

11 ;;; dropujemy po trzeciej probie
chain=input action=drop src-address-list=ssh_bruteforce

12 ;;; (proba 3) bruteforce ssh
chain=input action=add-src-to-address-list connection-state=new protocol=tcp src-address-list=ssh_2
address-list=ssh_bruteforce address-list-timeout=10m dst-port=22

13 ;;; (proba 2) bruteforce ssh
chain=input action=add-src-to-address-list connection-state=new protocol=tcp src-address-list=ssh_1
address-list=ssh_2 address-list-timeout=30s dst-port=22

14 ;;; (proba 1) ,bruteforce ssh koniec
chain=input action=add-src-to-address-list connection-state=new protocol=tcp src-address=!x.x.x.x/24
address-list=ssh_1 address-list-timeout=30s dst-port=22

W regułce 14 src-address=!x.x.x.x/24 dałem wyjątek tyczący się mojego lokala. Myślę że reszta jest w miarę jasne.


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Zdalne Logowanie.
PostNapisane: 12 maja 2009, godz. 09:59 
Offline

Dołączył(a): 7 maja 2009, godz. 10:07
Posty: 25
Dzieki bardzo, rozwialo troche watpliwosci, i dziala prawidlowo.


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Zdalne Logowanie.
PostNapisane: 19 maja 2009, godz. 14:12 
Offline

Dołączył(a): 1 kwietnia 2007, godz. 15:52
Posty: 61
Lokalizacja: Zdzieszowice
I ja trochę skorzystałem :)
Kolejny automacik ułatwiający życie. Dzięki.


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Zdalne Logowanie.
PostNapisane: 20 maja 2009, godz. 18:54 
Offline

Dołączył(a): 19 maja 2009, godz. 17:47
Posty: 2
Dobrze pomyślane regułki.

Jak zaczynałem przygode z MT to prostym sposobem likwidowałem ten problem - przenosiłem SSH z standardowego portu 22 na np. 2222 i cisza w logach.


:!: AkademiaWiFi.pl - Mikrotik Road Show 2009 :!:
.
.


Góra
 Zobacz profil Wyślij e-mail  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 7 ] 

Wszystkie czasy w strefie UTC + 1 [czas letni (DST)]


Kto przegląda forum

Użytkownicy przeglądający to forum: Brak zalogowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Publikowane wiadomości są prywatnymi opiniami użytkowników forum. Inter Projekt S.A. nie ponosi odpowiedzialności za treść wiadomości.
Informacje o cookies